Author Topic: HD Fury  (Read 23060 times)

Offline tsammyc

  • Trade Count: (0)
  • Full Member
  • Posts: 4885
  • I think, therefore I am
Re: HD Fury
« Reply #480 on: July 30, 2020, 22:21 »
I got the Vertex 2. Seemed really easy and used by someone in AVS with the 760ES.

I used his settings.


Construct Custom DV Data Block

DV Interface Low Latency 12 bit YCbCR 422 (haven't tried other options yet)
Primaries DCI P3
YUV 422 12 bit supported
Global Dimming not supported
Backlight not supported
Backlight min lum n/a

Set primaries. Unless you have your own values from calibrations, I suggest you stick to the standard RGB primaries.

Max luminance, set at 1000 nits to match the Ref HDR curve. Min luminance, set at 0.005, which seems to work well with projectors.

Click create, then send DV.



Setting Primaries to BT2020 instead of DCI-P3 seems to generate more natural color. Can anyone confirm?

Offline desray

  • Global Moderator
  • Trade Count: (+4)
  • Full Member
  • *
  • Posts: 20357
  • Bring the "Cinema experience" back home...
Re: HD Fury
« Reply #481 on: July 30, 2020, 22:29 »
Setting Primaries to BT2020 instead of DCI-P3 seems to generate more natural color. Can anyone confirm?

No diff in my case.

Offline tsammyc

  • Trade Count: (0)
  • Full Member
  • Posts: 4885
  • I think, therefore I am
Re: HD Fury
« Reply #482 on: July 31, 2020, 17:24 »
I think I figured it out. If you set the DV string to DCI-P3 and the projector is in BT2020, the colors will be off. However if both the DV string and projector are in DCI-P3, then all will be fine. Desray, perhaps your Sony projector can recognize between BT2020 and DCI-P3 and switch automatically between the two on the fly, but the BenQ can't and the colors will definitely be set differently. Just toggle between DCI-P3 and BT2020 on the DV tab, you will the the color primaries change on the same page. There is a reddish tint if you set the Vertex2 to DCI-P3 and the projector is BT2020. On my BenQ, I can't set to the pallete to DCI-P3, so I have to set the Vertex2 to BT2020. Previously, I was fiddling the colors to adjust for what I thought was oversaturation, but after selecting BT2020, the default unadjusted colors are fine.

I also noticed that the latest version of Vertex2 firmware 0.54, has added custom EDID #10 called Sony A1 LLDV BT2020, which does exactly this. 0.54 version also renames EDID #5 to Sony A1 LLDV DCI-P3. You can switch between the two to see the difference, which will essentially be changing the DV string between BT2020 and DCI-P3 when using Automix.

I remember Roni did a lot of calibration for his BenQ and has separate calibrations of LLDV and HDR10 using the different inputs of the W5700. I wonder if changing the DV string to BT2020 or using EDID #10 will allow him to use the HDR10 calibration with LLDV.

Offline tsammyc

  • Trade Count: (0)
  • Full Member
  • Posts: 4885
  • I think, therefore I am
Re: HD Fury
« Reply #483 on: July 31, 2020, 18:31 »
Here is a comment from AVS Forum on the same issue:

When you clicked the Create button, did you leave the Primaries drop down field at the default DCI-P3 or did you change it to ITU-R BT 2020-2 ? If DCI-P3 was selected, that will cause a red tint if your display device does not have a DCI-P3 color profile selected. The ITU-R BT 2020-2 primaries values will match up much better with the BT2020 color profile most display devices use for HDR10 content.

Offline tsammyc

  • Trade Count: (0)
  • Full Member
  • Posts: 4885
  • I think, therefore I am
Re: HD Fury
« Reply #484 on: July 31, 2020, 19:49 »
But still can’t get my Panasonic UB820 to play Gemini Man in LLDV 4K60.

I had originally set it to 4K60 4:4:4 which was recommended by HDTVtest a long time ago. And Deep Color at Auto (12bit).

I’ve tried different combinations of 4K60 4:2:0 and Off, and Deep Color to Auto (10bit) or Off. No go. The movie got past the warning screen I encountered yesterday but played at 1080p60 HDR.

At least switching to 4K60 4:2:0 now allows you to play my normal Dolby Vision 4K24 like Black Panther on the Panasonic. But I ended up switching it back to the original settings which I feel still looks better.



Doggie, try the latest version of Vertex2 firmware 0.54. Seems to have fixed some of the UB820 compatibility. Now, Auto works in addition to 4K. I still have issues with HDR10 UHDs on 4K 24 12bit 444 through the Vertex. Interestingly, turning off 24fps, it runs fine at upsampled 60fps. Also, seems to run if I turn change Auto 12 bits in the advanced section to Auto 10 bits or I change 444 to 420. I'm using Auto 10bits as the standard now because HDR10 is 10 bits anyway and LLDV switches to 12 bit output regardless

Offline desray

  • Global Moderator
  • Trade Count: (+4)
  • Full Member
  • *
  • Posts: 20357
  • Bring the "Cinema experience" back home...
Re: HD Fury
« Reply #485 on: July 31, 2020, 22:34 »
I think I figured it out. If you set the DV string to DCI-P3 and the projector is in BT2020, the colors will be off. However if both the DV string and projector are in DCI-P3, then all will be fine. Desray, perhaps your Sony projector can recognize between BT2020 and DCI-P3 and switch automatically between the two on the fly, but the BenQ can't and the colors will definitely be set differently. Just toggle between DCI-P3 and BT2020 on the DV tab, you will the the color primaries change on the same page. There is a reddish tint if you set the Vertex2 to DCI-P3 and the projector is BT2020. On my BenQ, I can't set to the pallete to DCI-P3, so I have to set the Vertex2 to BT2020. Previously, I was fiddling the colors to adjust for what I thought was oversaturation, but after selecting BT2020, the default unadjusted colors are fine.

I also noticed that the latest version of Vertex2 firmware 0.54, has added custom EDID #10 called Sony A1 LLDV BT2020, which does exactly this. 0.54 version also renames EDID #5 to Sony A1 LLDV DCI-P3. You can switch between the two to see the difference, which will essentially be changing the DV string between BT2020 and DCI-P3 when using Automix.


Frankly...no difference for me at all and I'm not surprised. I have calibrated my projector in DCI-P3 within the BT2020 color spectrum. My Sony projector will state BT2020 as the "main" container even though it is calibrated at DCI-P3. It is not possible to get good results if we calibrate at BT2020. Projector calibration is abit tricky compared to say an OLED TV where the latter can acheive higher color gamut since it is much harder for Projector to reproduce BT2020.

Offline tsammyc

  • Trade Count: (0)
  • Full Member
  • Posts: 4885
  • I think, therefore I am
Re: HD Fury
« Reply #486 on: August 01, 2020, 09:12 »
Although you have used DCI-P3 targets to calibrate, it is still within BT2020 so I imagine that you must set the Vertex2 to tell the player's LLDV algorithm to output to a BT2020 color space. With Automix, its sometimes hard to tell whether its telling DCI-P3 or BT2020 color space to the player (same effect on ATV4K, Firestick4K and UB820) because the page goes back to the default DCI-P3 after some time even though the instruction was sent to the Vertex2 and is permanent. It's clearer, if you switch between EDID #5 and EDID #10 under the EDID tab Custom setting. I'd be surprised if you don't see any color changes because they are fairly strong to me, say on Black Panther, where the black faces look too ruddy red if you have DCI-P3 selected on the Vertex2. Are you using firmware 0.54?

If you read this link that I posted before:
https://www.hdfury.eu/add-dv-support-to-any-hdr10-display/

you will see that when they originally figured out how to use the Vertex2 to spoof the Sony A1, there was a reddish tint on JVC projectors and someone made a DCI-P3 color profile for JVC projectors to fix it. Perhaps this is the same as your calibration to DCI-P3?

I am currently using Option 2 to get correct colors, which is "Mark's Custom BT20 EDID", but as of Vertex 0.54 firmware, they have integrated that EDID into Custom EDID #10

Offline desray

  • Global Moderator
  • Trade Count: (+4)
  • Full Member
  • *
  • Posts: 20357
  • Bring the "Cinema experience" back home...
Re: HD Fury
« Reply #487 on: August 01, 2020, 09:50 »
Although you have used DCI-P3 targets to calibrate, it is still within BT2020 so I imagine that you must set the Vertex2 to tell the player's LLDV algorithm to output to a BT2020 color space. With Automix, its sometimes hard to tell whether its telling DCI-P3 or BT2020 color space to the player (same effect on ATV4K, Firestick4K and UB820) because the page goes back to the default DCI-P3 after some time even though the instruction was sent to the Vertex2 and is permanent. It's clearer, if you switch between EDID #5 and EDID #10 under the EDID tab Custom setting. I'd be surprised if you don't see any color changes because they are fairly strong to me, say on Black Panther, where the black faces look too ruddy red if you have DCI-P3 selected on the Vertex2. Are you using firmware 0.54?

If you read this link that I posted before:
https://www.hdfury.eu/add-dv-support-to-any-hdr10-display/

you will see that when they originally figured out how to use the Vertex2 to spoof the Sony A1, there was a reddish tint on JVC projectors and someone made a DCI-P3 color profile for JVC projectors to fix it. Perhaps this is the same as your calibration to DCI-P3?

I am currently using Option 2 to get correct colors, which is "Mark's Custom BT20 EDID", but as of Vertex 0.54 firmware, they have integrated that EDID into Custom EDID #10

Maybe I set some background to the calibration procedure...When I did my calibration, I “bypass Vertex 2” and go straight to the source (a laptop) connected via my Denon AVR (pass through). I’m using Chromapure s/w for calibration...I shall not go into the nitty-gritty of how I perform my calibrations. Long story short, I only connect to Vertex 2 to get LLDV working. I calibrated using HDR10 base line which I have set as DCI-P3 with 75% color saturation. The projector will “always” show BT2020 as the primaries for my Sony projector, not sure about BenQ or other projectors though...

Switching between ITU BT2020 on the DV block or DCI-P3 didn’t show any sign of a “red push” as far as I can tell. To confirm, I will need to do a re-calibration with Vertex 2 connected this time and see whether it makes a difference when I have the time...right now I don’t intend to do it.

I will revert with more findings after I re-do my calibration...

Offline desray

  • Global Moderator
  • Trade Count: (+4)
  • Full Member
  • *
  • Posts: 20357
  • Bring the "Cinema experience" back home...
Re: HD Fury
« Reply #488 on: August 10, 2020, 12:05 »
There is a new firmware  - ver 0.55 but you probably don not need to update since there is nothing much in terms of new features. However there may be some custom EDID that you may want to test.

Changelog:
What's new/fixed in 0.55

- OSD screen output when NO INPUT routed is removed from this update, this is a test update to verify if this feature is indeed behind a few recents issues reported by users.

Download Link: https://hdfury.com/tools/Vertex2_FW_55.zip

Offline durianlover88

  • Trade Count: (+1)
  • Full Member
  • Posts: 4429
  • Forget Sound, Enjoy Music :)
Re: HD Fury
« Reply #489 on: August 11, 2020, 22:39 »
Any friends here can PM me Ovation United contact number? Sent a PM a few days ago but no response....I dun use Facebook...
For sale(neg):
Geek Out SIGNATURE Edition: S$999
Crystal Dreamlink 1m/Siltech Zero Ohm Diamond 1.5m: S$1888/S$2288
Acoustic Revive REM-8/RGC-24: S$388
Stillpoint Mini Ultra(3): S$299

Offline desray

  • Global Moderator
  • Trade Count: (+4)
  • Full Member
  • *
  • Posts: 20357
  • Bring the "Cinema experience" back home...
Re: HD Fury
« Reply #490 on: August 12, 2020, 07:21 »
Any friends here can PM me Ovation United contact number? Sent a PM a few days ago but no response....I dun use Facebook...

WhatsApp to 96872905/96948887

Offline winwinc81

  • Trade Count: (0)
  • Full Member
  • Posts: 382
Re: HD Fury
« Reply #491 on: August 12, 2020, 09:34 »
WhatsApp to 96872905/96948887

Thanks bro.

Offline winwinc81

  • Trade Count: (0)
  • Full Member
  • Posts: 382
Re: HD Fury
« Reply #492 on: August 12, 2020, 09:38 »
Any friends here can PM me Ovation United contact number? Sent a PM a few days ago but no response....I dun use Facebook...

sorry did not notice your PM. have replied you already. :)

Offline winwinc81

  • Trade Count: (0)
  • Full Member
  • Posts: 382
Re: HD Fury
« Reply #493 on: August 14, 2020, 17:45 »
Any friends here can PM me Ovation United contact number? Sent a PM a few days ago but no response....I dun use Facebook...

Thanks bro for the support! Have fun with your new toy!

Offline durianlover88

  • Trade Count: (+1)
  • Full Member
  • Posts: 4429
  • Forget Sound, Enjoy Music :)
Re: HD Fury
« Reply #494 on: August 14, 2020, 18:10 »
Thanks bro, hopefully not big learning curve....

I am slowly coming back to the hifi scene, and rebuilding my system....
For sale(neg):
Geek Out SIGNATURE Edition: S$999
Crystal Dreamlink 1m/Siltech Zero Ohm Diamond 1.5m: S$1888/S$2288
Acoustic Revive REM-8/RGC-24: S$388
Stillpoint Mini Ultra(3): S$299

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal